summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072022-06-01 23:29:26 +0200
committersL1pKn072022-06-01 23:29:26 +0200
commit9a21330b0afe3a64424f8eba423265667d0e518c (patch)
treeedba5dcf27c6467f868fc7ec9746b8d146861bfe /PKGBUILD
parente88d9d5f299ff07dab143bb5c86691281c97d27b (diff)
downloadaur-9a21330b0afe3a64424f8eba423265667d0e518c.tar.gz
Fix build with Qt +5.12 and swich source to tarball directly from the program developer github repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2ba4f4e8e28a..ba358e98e6d2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname=kamule
pkgver=0.91
-pkgrel=1
+pkgrel=2
pkgdesc="A KDE frontend for aMule"
-arch=("i686" "x86_64")
-url='http://kde-apps.org/content/show.php?content=150270'
+arch=('x86_64')
+url='https://www.linux-apps.com/content/show.php?content=150270'
license=('GPL')
depends=('amule-daemon'
'kio'
@@ -16,24 +16,26 @@ depends=('amule-daemon'
makedepends=('extra-cmake-modules'
'python'
)
-source=("https://dl.opendesktop.org/api/files/download/id/1466632134/150270-${pkgname}-${pkgver}.tar.bz2")
-sha1sums=('215a25efec9c487f4d14f338f251ba4e9b15f10c')
+#source=("https://dl.opendesktop.org/api/files/downloadfile/id/1466632134/s/2e53ec56530c00b50e3619c46b962da2/t/1523631790/u/76637/150270-${pkgname}-${pkgver}.tar.bz2")
+source=("${pkgname}-${pkgver}.tar.bz2::https://github.com/nihui/kamule/archive/refs/heads/master.zip")
+# sha256sums=('5e0f3abbc0ff1543abcbb9cfade7bb5658b2c6865c12e9b33a3bd1612592971d')
+sha256sums=('69b63b15636e8696d2494bae2d820f38fee0598f77235601e80fcdbfa675d816')
+options=('debug')
prepare() {
- mkdir -p build
+ sed '26a#include <QAction>' -i "${pkgname}-master/preferencepage.cpp"
}
build() {
- cd build
- cmake "../${pkgname}-${pkgver}" \
- -DCMAKE_BUILD_TYPE=Release \
+ cmake -S "${pkgname}-master" -B build \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTING=OFF \
-DKDE_INSTALL_USE_QT_SYS_PATHS=ON
- make
+
+ cmake --build build
}
package() {
- make -C build DESTDIR="$pkgdir" install
+ DESTDIR="${pkgdir}" cmake --install build
}
-