summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMuflone2023-11-14 00:31:30 +0100
committerMuflone2023-11-14 00:32:13 +0100
commit0b3ec55ed2e94eeab0a4799c038c085d760f58a5 (patch)
tree74acca6857476fc547bd62165071e11e7241a4ba /PKGBUILD
downloadaur-0b3ec55ed2e94eeab0a4799c038c085d760f58a5.tar.gz
New package kana 1.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e0b1f854724b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Muflone http://www.muflone.com/contacts/english/
+
+pkgname=kana
+pkgver=1.2
+pkgrel=1
+pkgdesc="Learn Japanese characters"
+arch=('x86_64')
+url="https://gitlab.gnome.org/fkinoshita/kana"
+license=("GPL3")
+depends=('gtk4' 'libadwaita')
+makedepends=('meson' 'rust')
+source=("https://gitlab.gnome.org/fkinoshita/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.bz2")
+sha256sums=('ad8987b25086a1db74a3517db574e2329e190d181e2f642781686e4e55c335de')
+
+prepare() {
+ cd "${pkgname}-v${pkgver}"
+ meson subprojects download
+}
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ arch-meson build
+ meson compile -C build
+}
+
+check() {
+ cd "${pkgname}-v${pkgver}"
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ meson install -C build --destdir "${pkgdir}"
+}
+