summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNiklasM2020-04-08 04:40:52 +0200
committerNiklasM2020-04-08 04:40:52 +0200
commitf1651f1b448dd460e279979e0e90807e8a8ff38f (patch)
treeaa644dcaeefec2eb1758c38452610223c0e039da /PKGBUILD
downloadaur-karaokemusicvideomanager.tar.gz
Add PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6277bf7b918e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: AnonymerNiklasistanonym <niklas.mikeler@gmail.com>
+pkgname=karaokemusicvideomanager
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='A software that scans folders after music videos, brings them together in a list and starts them'
+arch=('x86_64')
+url='https://github.com/AnonymerNiklasistanonym/KaraokeMusicVideoManager'
+license=('MIT')
+depends=('jdk8-openjdk' 'java8-openjfx')
+makedepends=('maven' 'python')
+provides=("$pkgname")
+conflicts=("$pkgname")
+_gitname="$pkgname.git"
+source=("$_gitname::git+$url#branch=master")
+sha1sums=('SKIP')
+
+build() {
+ cd "$_gitname"
+ make build
+ make dist
+}
+
+package() {
+ cd "$_gitname"
+ make DESTDIR="$pkgdir" install install_desktop
+}