summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzer0def2021-05-22 11:22:11 +0200
committerzer0def2021-05-22 11:22:11 +0200
commit2dacaedd81842b693b3e2268a0f7e78bd5d2a956 (patch)
tree5db7c65b1cfc6d44304b7fdd664a86dc1b509458 /PKGBUILD
parent36fb812a7533676045e21510276c819f16036582 (diff)
downloadaur-2dacaedd81842b693b3e2268a0f7e78bd5d2a956.tar.gz
Move guest components and hypervisors to optdeps for users to pick from
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da80ecd29d01..161b13c35fbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ pkgname=(
)
pkgver=2.1.0
_pkgver=${pkgver/\~/-}
-pkgrel=2
+pkgrel=3
pkgdesc="Lightweight virtual machines for containers, version 2"
arch=('x86_64')
url="https://katacontainers.io/"
@@ -138,10 +138,12 @@ package_kata-containers-image(){
}
package_kata-runtime(){
- depends=('qemu-headless' "linux-kata" "kata-containers-image")
optdepends=(
- 'firecracker<0.24.0'
- 'cloud-hypervisor<16.0'
+ 'kata-containers-image: Disk and initrd images for booting Kata VMs'
+ 'linux-kata: Kernel images for booting Kata VMs'
+ 'qemu-headless: QEMU-hypervised Kata VMs'
+ 'cloud-hypervisor<16.0: Cloud-Hypervisor-based Kata VMs'
+ 'firecracker<0.24.0: Firecracker-based Kata VMs'
)
install=kata2-runtime.install
cd "${srcdir}/${pkgbase}-${_pkgver}/src/runtime"