summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzer0def2021-01-15 08:49:20 +0100
committerzer0def2021-01-15 08:49:20 +0100
commit313f1ff5845c0a83a1b7fc1b63bfe54faa603268 (patch)
treed91c1880396e3d57c32e4207477b575328489232 /PKGBUILD
parent5fe8d807a2086bb6704442e233f0405dbde9f03f (diff)
downloadaur-kata-containers-git.tar.gz
Use Kata's yq to pull values from their versions.yaml.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8a495400ee0d..72358a897e27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,18 @@ pkgname=(
kata-proxy-git
kata-shim-git
)
-pkgver=1.12.0~rc0~runtime.r14.c54378d7
+pkgver=1.13.0~alpha0~runtime.r0.cd63aacc
pkgrel=1
pkgdesc="Lightweight virtual machines for containers (Git version)"
arch=('x86_64')
url="https://katacontainers.io/"
license=('Apache')
-makedepends=('go' 'yq2-bin' 'bc' 'git')
+makedepends=(
+ 'go'
+ #'yq2-bin'
+ 'bc'
+ 'git'
+)
_gh_org="github.com/kata-containers"
source=(
"ksm-throttler::git+https://${_gh_org}/ksm-throttler"
@@ -33,8 +38,8 @@ pkgver(){
prepare(){
# kata-runtime makedep
- mkdir -p "${srcdir}/bin"
- ln -sf "$(type -p yq)" "${srcdir}/bin/yq"
+ #mkdir -p "${srcdir}/bin"
+ #ln -sf "$(command -v yq)" "${srcdir}/bin/yq"
mkdir -p "${srcdir}/src/${_gh_org}"
for i in ksm-throttler proxy runtime shim; do