summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgnebbia2020-09-25 18:17:20 +0200
committergnebbia2020-09-25 18:17:20 +0200
commit800c520fc7bf12d0771d806627c400ede29392b9 (patch)
tree9a1ed642881c2df187d0e5e095c82b67b058e2ed /PKGBUILD
downloadaur-800c520fc7bf12d0771d806627c400ede29392b9.tar.gz
Initial push
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f6ed5274cfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Giuseppe Nebbione <giuseppenebbione at gmail dot com>
+
+pkgbase='kb'
+pkgname=('kb')
+_module='kb-manager'
+pkgver='0.1.3'
+pkgrel=1
+pkgdesc="A command line minimalist knowledge base manager"
+url="https://github.com/gnebbia/kb"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
+sha256sums=('78e14f6eef30a4742925cc75ba9a5509c032ae42e73e26582cd7ed91794f41df')
+
+build() {
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd "${srcdir}/${_module}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}