summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAntonio Rojas2015-06-08 22:23:11 +0200
committerAntonio Rojas2015-06-08 22:23:11 +0200
commitb6fd49d0fda2931f3de9c23ade032d7bc88123a9 (patch)
tree55fb34e4f75d014ab2490392b9c7aeb84c475851 /PKGBUILD
downloadaur-b6fd49d0fda2931f3de9c23ade032d7bc88123a9.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..060ac771c56e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Antonio Rojas <nqn1976 @ gmail.com>
+
+pkgname=kbackgammon
+_pkgname=backgammon
+pkgver=0.18
+_pkgver=018
+pkgrel=2
+pkgdesc="Backgammon game for KDE"
+arch=('i686' 'x86_64')
+url="http://kde-apps.org/content/show.php/KBackgammon?content=142680"
+license=('GPL')
+depends=('kdebase-runtime' 'libkdegames')
+makedepends=('cmake' 'automoc4')
+source=("http://kde-apps.org/CONTENT/content-files/142680-${_pkgname}_${_pkgver}.tar.gz")
+install=$pkgname.install
+md5sums=('4c3a404f80e12b67c34f8da23159a4d4')
+
+build() {
+ cd ${_pkgname}
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd ${_pkgname}/build
+ make DESTDIR="$pkgdir" install
+}