summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-10-22 01:15:32 +0300
committerOrhun Parmaksız2021-10-22 01:15:32 +0300
commit0884c83b948c41e0c5f8da51b62e17a6f2b1bcb7 (patch)
treeb83229b2c85d0a2c244fbafc421bd4237860d803 /PKGBUILD
parent304a802297da4425aa73546b9b0530ee76335e68 (diff)
downloadaur-0884c83b948c41e0c5f8da51b62e17a6f2b1bcb7.tar.gz
upgpkg: kbs2-bin 0.4.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ca499890a23..500d2db606bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=kbs2-bin
-pkgver=0.3.0
+pkgver=0.4.0
pkgrel=1
pkgdesc="A secret manager backed by age"
arch=('x86_64')
@@ -12,13 +12,13 @@ depends=('libx11' 'gcc-libs')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}")
source_x86_64=("$url/releases/download/v$pkgver/${pkgname%-bin}-linux-v${pkgver}.tar.gz")
-sha256sums_x86_64=('56de58606d74e325e549eec92fc40a94a4ae5f04d1938b3537f333d65322d9e4')
+sha256sums_x86_64=('b5a5536be20fa48f7d2932bd4fc5fc7ac2300a79f351ae1d5436298e346e1e4e')
package() {
install -Dm 755 "${pkgname%-bin}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
"./${pkgname%-bin}" --completions bash | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-bin}"
- "./${pkgname%-bin}" --completions fish | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/fish/completions/${pkgname%-bin}.fish"
+ "./${pkgname%-bin}" --completions fish | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/fish/vendor_completions.d/${pkgname%-bin}.fish"
"./${pkgname%-bin}" --completions zsh | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname%-bin}"
}