summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authororhun2020-12-09 19:54:26 +0300
committerorhun2020-12-09 19:54:26 +0300
commitb28e602bd66430ff27d469ea809eedc2116c25fa (patch)
tree35d0b77be60a7e92c309d2b124c27d79fabf3783 /PKGBUILD
parentfa2ac6e03450b418069ac8a62d9ad85fc4b54172 (diff)
downloadaur-b28e602bd66430ff27d469ea809eedc2116c25fa.tar.gz
upgpkg: kbs2-git 0.2.2.r4.g408fb12-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d2cb3714057..9be5c3690a4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=kbs2-git
-pkgver=0.2.1.r0.g7c72d08
+pkgver=0.2.2.r4.g408fb12
pkgrel=1
pkgdesc="A secret manager backed by age (git)"
arch=('x86_64')
@@ -35,4 +35,7 @@ package() {
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"
install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ "${pkgname%-git}" --completions bash | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/${pkgname%-git}"
+ "${pkgname%-git}" --completions fish | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/fish/completions/${pkgname%-git}.fish"
+ "${pkgname%-git}" --completions zsh | install -Dm 644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_${pkgname%-git}"
}