summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLEVAI Daniel2024-03-07 12:22:26 +0100
committerLEVAI Daniel2024-03-07 12:22:26 +0100
commit79c773579750e0c00c0d8a2017b75bd08346c40e (patch)
tree0ad80f671c862ccc31411bc57f0b33c39a6ffb55 /PKGBUILD
downloadaur-79c773579750e0c00c0d8a2017b75bd08346c40e.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a34dff9bc1a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Levai, Daniel <leva at ecentrum.hu>
+
+pkgbase='kc'
+pkgname='kc'
+pkgver=2.5.3
+pkgrel=1
+pkgdesc="console-based password storing application"
+arch=('any')
+url="https://github.com/levaidaniel/kc"
+license=('BSD-2-Clause')
+depends=('libbsd>=0.2.0',
+'libxml2>=2.6.0',
+'openssl>=1.1.1',
+'readline'
+)
+source=("${pkgbase}-${pkgver}.tar.gz::https://github.com/levaidaniel/${pkgbase}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('593db34bf53ad9197c3ac1ffc3742dfc03a784862f0a5fadeda6b6d2ad287539')
+
+
+build() {
+ cd "${pkgbase}-${pkgver}"
+ make -f Makefile.linux
+}
+
+package() {
+ cd "${pkgbase}-${pkgver}"
+ make -f Makefile.linux install DESTDIR="${pkgdir}/" PREFIX=/usr
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 'Changelog.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
+ install -m644 'README.md' -t "${pkgdir}/usr/share/doc/${pkgname}/"
+}