summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJianqiu Zhang2019-03-21 09:56:52 +0800
committerJianqiu Zhang2019-03-21 09:56:52 +0800
commite81f9beec2c23afd6ed6bc2fe0e8db4ec4ebf61e (patch)
treec50a0fed6af4eda6a6095c9c65267536516fd68b /PKGBUILD
parenta07fe1fb2fa6599d39d03fe96d832fdf09922fe0 (diff)
downloadaur-kcm-colorful-git.tar.gz
kcm-colorful-git: update PKGBUILD
Signed-off-by: Jianqiu Zhang <zhangjianqiu13@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc00c4d46bcb..38bbb31647c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=kcm-colorful-git
pkgrel=1
-pkgver=0.0.2
+pkgver=0.9.6.r0.g22ffde1
pkgdesc='Make your KDE plasma colorful'
arch=('x86_64')
url="https://github.com/IsoaSFlus/kcm-colorful"
license=('GPL2')
-depends=('kconfigwidgets')
+depends=('systemsettings' 'kcolorchooser')
makedepends=('cmake' 'git' 'extra-cmake-modules' 'qt5-base' 'frameworkintegration' 'kcmutils')
source=(
@@ -18,11 +18,12 @@ source=(
sha256sums=('SKIP')
pkgver() {
+ cd "$srcdir"/kcm-colorful
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd $srcdir/kcm-colorful
+ cd "$srcdir"/kcm-colorful
git submodule init
git submodule update
}
@@ -31,11 +32,14 @@ build() {
cd $srcdir/kcm-colorful
mkdir -p build
cd build
- cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" ..
+ cmake -DCMAKE_INSTALL_PREFIX="/usr" \
+ -DCMAKE_INSTALL_LIBDIR="lib" \
+ -DBUILD_TESTING=OFF \
+ ..
make
}
package() {
cd $srcdir/kcm-colorful/build
- make install
+ make DESTDIR="$pkgdir/" install
}