summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukáš Jirkovský2015-08-18 23:23:16 +0200
committerLukáš Jirkovský2015-08-18 23:23:16 +0200
commita234e5d785dd03644b2a5c6f72735e3739cc33a5 (patch)
tree3ae4fb0183738f8f6575374a50fd5c7bdc1c17bb /PKGBUILD
downloadaur-a234e5d785dd03644b2a5c6f72735e3739cc33a5.tar.gz
initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d8d3c928fd4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Lukas Jirkovsky <l.jirkovsky@gmail.com>
+# Contributor: BlackEagle < ike DOT devolder AT gmail DOT com >
+# Contributor: Dany Martineau <dany.luc.martineau at gmail.com>
+# Contributor: Dylon Edwards <deltaecho@archlinux.us>
+pkgname=kcm-wacomtablet
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="KDE GUI for the Wacom Linux Drivers"
+arch=('i686' 'x86_64')
+url="http://kde-apps.org/content/show.php/wacom+tablet?content=114856"
+license=('GPL2')
+depends=('kdebase-workspace' 'xf86-input-wacom')
+makedepends=('cmake' 'automoc4')
+source=("http://kde-apps.org/CONTENT/content-files/114856-wacomtablet-${pkgver}.tar.xz")
+md5sums=('fb2f3eefa6ac7e3c7b07a42ea4f6624c')
+
+build() {
+ cd "$srcdir/wacomtablet-$pkgver"
+
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/wacomtablet-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+