summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorh8red2016-07-11 13:26:42 +0300
committerh8red2016-07-11 13:26:42 +0300
commitc174e151e6ef31e433ef2a22079182efc9c65958 (patch)
treecca6b48ef5f041f69f413bfdfaf7e91a7c38e841 /PKGBUILD
parent532e487e7941f8ba35bea398080c043d96fd2af2 (diff)
downloadaur-c174e151e6ef31e433ef2a22079182efc9c65958.tar.gz
add fix_isnan_scope.patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fc28e93d6775..67cbe3cd96a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: h8red h8red at yandex dot ru
pkgname=kcollectd
pkgver=0.9
-pkgrel=2.1
+pkgrel=2.2
pkgdesc="Kcollectd is a small applications that allows to view rrd datacollections that have been created by collectd."
arch=('i686' 'x86_64')
url="http://www.forwiss.uni-passau.de/~berberic/Linux/kcollectd.html"
@@ -15,17 +15,20 @@ replaces=()
backup=()
options=()
source=(http://www.forwiss.uni-passau.de/~berberic/Linux/kcollectd/$pkgname-$pkgver.tar.gz
- http://ftp.de.debian.org/debian/pool/main/k/kcollectd/$pkgname'_'$pkgver-$pkgrel.diff.gz
+ http://ftp.de.debian.org/debian/pool/main/k/kcollectd/$pkgname'_'0.9-2.1.diff.gz
default_source.patch
+ fix_isnan_scope.patch
)
noextract=()
md5sums=('7fef4a660207b4c65520ee77334088fb'
'7dc0a3be745aa5156946fe6c9cec5405'
- '0680cad562a4f157bc41fca56c6ac170')
+ '0680cad562a4f157bc41fca56c6ac170'
+ '99d5797e67331de96dbba9354241fba3')
build() {
cd $srcdir
- patch -p0 -i $pkgname'_'$pkgver-$pkgrel.diff
+ patch -p0 -i $pkgname'_'0.9-2.1.diff
patch -p0 -i default_source.patch
+ patch -p0 -i fix_isnan_scope.patch
cd $pkgname-$pkgver
mkdir build && cd build
cmake -DCMAKE_INSTALL_PREFIX=`kde4-config --prefix` .. || return 1