summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoroioi 5552023-12-29 19:25:40 +0900
committeroioi 5552023-12-29 19:25:40 +0900
commita16bd04a00eb2913a5590cb5dd99d03146d470b2 (patch)
tree1e69bc8ba69218580614af9ca29fce791ada3c56 /PKGBUILD
downloadaur-a16bd04a00eb2913a5590cb5dd99d03146d470b2.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..821df2f9b99a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=kde-fcstd-thumbnailer-git
+pkgver=2.0.0
+pkgrel=1
+pkgdesc='FreeCAD Thumbnail Creator.'
+arch=('i686' 'x86_64')
+url='https://github.com/StefanHamminga/kde-fcstd-thumbnailer'
+license=('GPL3')
+
+depends=('qt5-base' 'kio5')
+makedepends=('cmake' 'extra-cmake-modules' 'qt5-tools')
+provides=(${pkgname}=${pkgver})
+conflicts=(${pkgname})
+replaces=(${pkgname})
+source=("${pkgname}::git+${url}.git")
+sha256sums=('SKIP')
+
+build() {
+ cd ${srcdir}/${pkgname}/
+ cmake -B build -DCMAKE_PREFIX_PATH:PATH=/usr/lib/cmake/Qt5
+ cmake --build build
+}
+
+package() {
+ cd ${srcdir}/${pkgname}/
+ install -Dm644 ./build/fcstdthumbnailer.so ${pkgdir}/usr/lib/qt/plugins/fcstdthumbnailer.so
+ install -Dm644 ./src/fcstdthumbnailer.desktop ${pkgdir}/usr/share/kservices5/fcstdthumbnailer.desktop
+}