summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuca Weiss2016-10-14 22:13:09 +0200
committerLuca Weiss2016-10-14 22:13:09 +0200
commit5725752484c236f357a8b3e1f80f9e9ec8ed3fc0 (patch)
tree1333aea7bf167ca2547e4be08769bdc3bb7269b1 /PKGBUILD
parent2e2f0d266e160e16bc02796192d44516752d5714 (diff)
downloadaur-5725752484c236f357a8b3e1f80f9e9ec8ed3fc0.tar.gz
Add patches and bump to pkgrel 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0707a0b2fa37..17642ccea783 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kde1-kdebase
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Historical copy of the base applications module of KDE 1, adapted to compile on modern systems (circa. 2016)"
arch=('i686' 'x86_64')
url="https://github.com/KDE/kde1-kdebase"
@@ -11,8 +11,18 @@ groups=("kde1")
depends=("qt1" "kde1-kdelibs" "libjpeg" "libtiff" "perl")
makedepends=("cmake")
_commit="07492489711904daf165c633549883000a71295a"
-source=("https://github.com/KDE/$pkgname/archive/$_commit.zip")
-sha256sums=('8f2f84b941af1b018ae4a86d41e6ff3a7e952254cfae32bc959c797fe49ae128')
+source=("https://github.com/KDE/$pkgname/archive/$_commit.zip"
+ "kfm_CMakeLists.patch"
+ "kwm_CMakeLists.patch")
+sha256sums=('8f2f84b941af1b018ae4a86d41e6ff3a7e952254cfae32bc959c797fe49ae128'
+ 'fd73241c7f1ee4847b431c5515fc74828aab50831118d9d2a99916c3b256ef86'
+ '82a0fff5971adb92c9140b16a4b6b13c832ff7b7b6e3217fe9edf0dd3505d304')
+
+prepare() {
+ cd $srcdir/$pkgname-$_commit
+ patch -p1 kfm/pics/CMakeLists.txt < $srcdir/kfm_CMakeLists.patch
+ patch -p1 kwm/pics/CMakeLists.txt < $srcdir/kwm_CMakeLists.patch
+}
build() {
cd $srcdir/$pkgname-$_commit