summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMathias Roux2020-02-17 21:20:36 +0100
committerMathias Roux2020-02-17 21:20:36 +0100
commit3aef87dd7da29b776b90eb2bf8cf1c9b92d78e56 (patch)
treefcdc5125c7d438fdf7a10731b1af2d3a102779a3 /PKGBUILD
parent7803fc4982815401f772d2c7d1424a21b17c1fe7 (diff)
downloadaur-3aef87dd7da29b776b90eb2bf8cf1c9b92d78e56.tar.gz
a
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96bcd958fd4d..6b7e20cedd87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
#Maintainer: Mathias Roux <poussinberlin@gmail.com>
#Based on the official kdeconnect PKGBUILD
-pkgname=kdeconnect-bluetooth
+_name=kdeconnect
+pkgname=$_name-bluetooth
pkgver=1.4
pkgrel=1
pkgdesc='Adds communication between KDE and your smartphone, with a bluetooth backend'
@@ -11,7 +12,7 @@ depends=(hicolor-icon-theme kcmutils kwayland libfakekey qca kpeoplevcard pulsea
makedepends=(extra-cmake-modules kdoctools)
optdepends=('sshfs: remote filesystem browser' 'python-nautilus: Nautilus integration' 'bluez: Basic bluetooth support')
provides=('kdeconnect')
-source=("https://download.kde.org/stable/kdeconnect/$pkgver/kdeconnect-kde-$pkgver.tar.xz"{,.sig})
+source=("https://download.kde.org/stable/$_name/$pkgver/$_name-kde-$pkgver.tar.xz"{,.sig})
sha256sums=('caee7945a9d9bb881a943dc8d2fd0d702c04da5bdb2df14d4f875e7cf5d5261a'
'SKIP')
validpgpkeys=(B3487CA0FF36258E2A2F338BD33E721DF877EFE8 # Albert Vaca Cintora <albertvaka@gmail.com>
@@ -24,7 +25,7 @@ prepare() {
build() {
cd build
- cmake ../$pkgname-kde-$pkgver \
+ cmake ../$_name-kde-$pkgver \
-DBUILD_TESTING=OFF \
-DCMAKE_INSTALL_LIBEXECDIR=lib\
-DBLUETOOTH_ENABLED=ON