summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2021-08-29 23:59:32 +0100
committerJoão Figueiredo2021-08-29 23:59:32 +0100
commita194349315685ee0062a6946ef32e3769f12ca89 (patch)
tree566b442c828900f39137033b232826a2130d378d /PKGBUILD
downloadaur-a194349315685ee0062a6946ef32e3769f12ca89.tar.gz
Merged with official ABS kdegraphics-thumbnailers PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d157c43ffa4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Merged with official ABS kdegraphics-thumbnailers PKGBUILD by João, 2021/08/25 (all respective contributors apply herein)
+# Maintainer: João Figueiredo & chaotic-aur <islandc0der@chaotic.cx>
+
+pkgname=kdegraphics-thumbnailers-git
+pkgver=21.07.90_r236.g918502e
+pkgrel=1
+pkgdesc='Thumbnailers for various graphics file formats'
+url='https://apps.kde.org/kdegraphics_thumbnailers/'
+arch=($CARCH)
+license=(GPL LGPL FDL)
+depends=(libkexiv2-git libkdcraw-git kio-git ghostscript)
+makedepends=(git extra-cmake-modules-git)
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+groups=(kde-applications-git kde-graphics-git)
+source=("git+https://github.com/KDE/${pkgname%-git}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-git}
+ _ver="$(git describe | sed 's/^v//;s/-.*//')"
+ echo "${_ver}_r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cmake -B build -S ${pkgname%-git} \
+ -DBUILD_TESTING=OFF
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}