summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndré Kugland2023-08-02 15:38:42 -0300
committerAndré Kugland2023-08-02 15:40:39 -0300
commitd2a97508b1802d94e32ba6ed570f0b0d4aca463b (patch)
treec69a6afc4c4ee9ee6fe477f0799e83aec1ec2dce /PKGBUILD
parent2641a07b5bcb21c955b530c2b1f115a38f24672a (diff)
downloadaur-d2a97508b1802d94e32ba6ed570f0b0d4aca463b.tar.gz
Now it builds at least. Thanks dreieck!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7eb90c8da023..74dfd290017f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=kdelibs
pkgver=4.14.38
_kdeappver=17.08.3
-pkgrel=5
+pkgrel=7
pkgdesc="KDE Core Libraries"
arch=('x86_64')
url='https://www.kde.org/'
@@ -16,10 +16,12 @@ depends=('attica-qt4' 'libxss' 'libdbusmenu-qt4' 'polkit-qt4'
'docbook-xsl' 'upower' 'udisks2' 'libxcursor' 'phonon-qt4'
'media-player-info' 'libutempter' 'icu')
makedepends=('cmake' 'automoc4' 'avahi' 'libgl' 'mesa')
+conflicts=('arrow') # 'arrow' also installs a -- unrelated but same name -- file /usr/lib/libplasma.so
source=("https://download.kde.org/stable/applications/${_kdeappver}/src/$pkgname-$pkgver.tar.xz"
'kde-applications-menu.patch' 'archlinux-menu.patch' 'qt4.patch'
'kdelibs-no-kdewebkit.patch' 'kdelibs-openssl-1.1.patch'
- 'patch-klocale-kde.cpp.patch' 'ordered.patch')
+ 'patch-klocale-kde.cpp.patch' 'ordered.patch'
+ 'use-only-exported-libjasper-functions.patch')
sha256sums=('37fd43a34e8118406e03a5d0e53f4a03c8aa50b219e8484a5d42349dc0f2c3fe'
'0eed754cf3e9f41be5ea22314bf49cf5571b421d81b8f525287830bd1b9b684e'
'877df7357360b70d9f7d6bc8c211f82fd8b00cc2eb34e9993ff6aae20faf1cad'
@@ -27,7 +29,8 @@ sha256sums=('37fd43a34e8118406e03a5d0e53f4a03c8aa50b219e8484a5d42349dc0f2c3fe'
'2df372f1bfcef1902349f9ca8820315030d39dd2bb769776b94fd3fcbf9621f5'
'42f86279515bead6e9f89b1fc3ea58e0a648d41fae343de95297f995dedcdd71'
'e2e7cf3fe5c82d18609d51d4d224c17a55b0bac77c1fce5e32296381d34a14fa'
- '7b621b8c72ffd662e933601dc6cd7638270cfa2d6d36e0f2deb682dd37c442bd')
+ '7b621b8c72ffd662e933601dc6cd7638270cfa2d6d36e0f2deb682dd37c442bd'
+ 'ca716ab3a6a4883654dafaec4ecf928d4fd5f063e67f2fdb4bf9cbbd88dd47b3')
prepare() {
mkdir -p build
@@ -46,6 +49,8 @@ prepare() {
patch -p1 -i ../patch-klocale-kde.cpp.patch
# fix error: ordered comparison of pointer with integer zero
patch -p1 -i ../ordered.patch
+ # fix error "undefined reference to `jp2_encode'". For background see https://github.com/mxe/mxe/issues/1896#issuecomment-334296523, patch is inspired by https://invent.kde.org/graphics/digikam/-/commit/56ba3493e4b06ba43546c87dec09f0e2cd42acc5.
+ patch -p1 -i ../use-only-exported-libjasper-functions.patch
}
build() {