summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Hacohen2020-08-21 14:40:19 +0300
committerTom Hacohen2020-08-21 14:40:19 +0300
commit72d70baa895166b6546aa151f336a3636080f829 (patch)
tree840f182b2a41c29ed80508a9ad490dc09342c5fd /PKGBUILD
parent59723929c8193264c4c192087621fbbff64661e9 (diff)
downloadaur-72d70baa895166b6546aa151f336a3636080f829.tar.gz
Improve version string calculation and add git to makedpends.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d8cb63fdfc5..762158bcd75d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
pkgname=kdepim-runtime-etesync-git
_pkgname=kdepim-runtime-etesync
-pkgver=v20.04.1.r188.g7de456e37
+pkgver=v20.04.1.r189.gbed707724
pkgrel=1
pkgdesc='Extends the functionality of kdepim (with etesync modules)'
arch=(x86_64)
url='https://kontact.kde.org'
license=(GPL LGPL FDL)
depends=(libkolabxml kdav akonadi-calendar knotifyconfig kalarmcal kmbox pimcommon akonadi-notes akonadi libakonadi qca qt5-networkauth etesync)
-makedepends=(extra-cmake-modules kdoctools boost)
+makedepends=(extra-cmake-modules kdoctools boost git)
provides=(kdepim-runtime)
conflicts=(kdepim-runtime)
source=("${_pkgname}::git+https://invent.kde.org/sjolly/kdepim-runtime.git#branch=etesyncResource"
@@ -19,7 +19,7 @@ sha512sums=('SKIP'
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | awk -F '-' '/-/{ printf "%s.r%3.3d.%s\n", $1, $2, $3 }'
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {