summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Hacohen2020-11-07 10:13:19 +0200
committerTom Hacohen2020-11-07 10:15:30 +0200
commite606b353149e70b56dbea0a95187e02af5f30ec6 (patch)
tree2948a6f0dfd0a01e8cfce272c2659cca9adfdfc1 /PKGBUILD
parent5aa2f58fa06e115a07a393842f5fac1999776fcf (diff)
downloadaur-e606b353149e70b56dbea0a95187e02af5f30ec6.tar.gz
Change the package to only build and install the etesync resource.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 8 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5375c86d2e39..e56db8cc6a8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,15 @@ pkgdesc='Extends the functionality of kdepim (with etesync modules)'
arch=(x86_64)
url='https://kontact.kde.org'
license=(GPL LGPL FDL)
-depends=(libkolabxml kdav akonadi-calendar knotifyconfig kalarmcal kmbox pimcommon akonadi-notes akonadi libakonadi qca qt5-networkauth etebase)
+depends=(libkolabxml kdav akonadi-calendar knotifyconfig kalarmcal kmbox pimcommon akonadi-notes akonadi qca qt5-networkauth kdepim-runtime etebase)
makedepends=(extra-cmake-modules kdoctools boost git)
-provides=(kdepim-runtime)
-conflicts=(kdepim-runtime)
source=("${_pkgname}::git+https://invent.kde.org/pim/kdepim-runtime"
- "0001-XXX-Ease-version-requirements.patch")
+ "0001-XXX-Ease-version-requirements.patch"
+ )
sha512sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ 'SKIP'
+ )
pkgver() {
cd "$srcdir/$_pkgname"
@@ -30,9 +31,9 @@ prepare() {
build() {
cmake -B build -S "${_pkgname}" \
-DBUILD_TESTING=OFF
- cmake --build build
+ cmake --build build/resources/etesync
}
package() {
- DESTDIR="$pkgdir" cmake --install build
+ DESTDIR="$pkgdir" cmake --install build/resources/etesync
}