summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbirdflesh2015-06-09 19:42:40 +0300
committerbirdflesh2015-06-09 19:42:40 +0300
commit263c1aa601b5643c53d89d12a703d1336084da1f (patch)
tree719f2705261078f41a3d7deed9acd419c328780d /PKGBUILD
downloadaur-263c1aa601b5643c53d89d12a703d1336084da1f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61e5ee4e252f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: birdflesh <antkoul at gmail dot com>
+# Contributor: Carl Mueller archlinux at carlm e4ward com
+
+pkgname=kdeplasma-applets-cwp
+_pkgname=cwp
+pkgver=1.12.0
+pkgrel=1
+pkgdesc="Customizable weather plasmoid"
+arch=('i686' 'x86_64')
+url="http://kde-look.org/content/show.php?content=98925"
+license=('GPL3')
+depends=('kdelibs')
+makedepends=('cmake' 'automoc4')
+source=("http://kde-look.org/CONTENT/content-files/98925-$_pkgname-$pkgver.tar.bz2")
+md5sums=('b05d9dec29a73629ae7fb07ac718bc2b')
+
+build() {
+ cd "$srcdir"
+ mkdir build
+ cd build
+ cmake ../$_pkgname-$pkgver \
+ -DQT_QMAKE_EXECUTABLE=qmake-qt4 \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+ make DESTDIR="$pkgdir" install
+}