summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Hasting2022-04-04 17:13:14 -0400
committerDan Hasting2022-04-04 17:13:14 -0400
commit3d8cecec68d3900e06a20c64fb0418d76d55287e (patch)
tree45d88ca3c17f1a22b04449a34514c50380835819 /PKGBUILD
parent4a55352302020679156066512206e73790764bfd (diff)
downloadaur-3d8cecec68d3900e06a20c64fb0418d76d55287e.tar.gz
Add patch to fix deadlocks
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dad51483f2b2..f6b0d873de01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,20 @@
pkgname=kdocker
pkgver=5.3
-pkgrel=1
+pkgrel=2
pkgdesc="An application to help you dock any application into the system tray"
arch=('i686' 'x86_64')
url="https://github.com/user-none/KDocker"
license=('GPL2')
depends=('qt5-base' 'qt5-x11extras' 'libxpm' 'libxmu')
-source=(https://github.com/user-none/KDocker/archive/${pkgver}.tar.gz)
-sha256sums=('c49eea33d46a626b2a59c8ddc923ce9a027f0b9bd2125f4f6c264e888997e663')
+source=(https://github.com/user-none/KDocker/archive/${pkgver}.tar.gz
+ 'fix-deadlock.patch')
+sha256sums=('c49eea33d46a626b2a59c8ddc923ce9a027f0b9bd2125f4f6c264e888997e663'
+ '731edac829b4231ddf87f3ed6cd043df4c2026bec4dc26dd11c22ad79876bcbd')
+
+prepare() {
+ cd "$srcdir/KDocker-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/fix-deadlock.patch"
+}
build() {
cd "$srcdir/KDocker-$pkgver"