summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeff Henson2019-01-18 19:44:20 -0700
committerJeff Henson2019-01-18 19:44:20 -0700
commit1c23088f57b2132ce5b626951f83002e3ae289e5 (patch)
tree35a7590a3c15c08d807a87bf2b5e360e84af9fa2 /PKGBUILD
downloadaur-1c23088f57b2132ce5b626951f83002e3ae289e5.tar.gz
Inital commit - v1.3.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..77f0f9a94fd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Jeff Henson <jeff at henson dot io>
+
+pkgname=keepass-plugin-hibpofflinecheck
+_pluginname=HIBPOfflineCheck
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Keepass plugin that performs offline checks against the haveibeenpwned passwords file"
+depends=('keepass')
+arch=('any')
+url="https://github.com/mihaifm/HIBPOfflineCheck"
+source=("${_pluginname}-${pkgver}.tar.gz::https://github.com/mihaifm/${_pluginname}/archive/${pkgver}.tar.gz")
+sha256sums=('4000cdac827a0455ad2b73c3c91278b8037db82a36198f8f06a24877b8f9f9ee')
+
+prepare() {
+ cd "${srcdir}/${_pluginname}-${pkgver}"
+ mkdir build
+ cp -r Properties *.cs *.resx *.csproj *.sln build/
+}
+
+build() {
+ keepass --plgx-create "${srcdir}/${_pluginname}-${pkgver}/build"
+}
+
+package() {
+ install -Dm644 "${srcdir}/${_pluginname}-${pkgver}/build.plgx" "${pkgdir}/usr/share/keepass/plugins/${_pluginname}.plgx"
+}