summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiancarlo Razzolini2015-07-10 11:50:36 -0300
committerGiancarlo Razzolini2015-07-10 11:50:36 -0300
commitbc8fa4321290be7c2a542375d8aca9996e0f5470 (patch)
tree6f801d735a2067b308a8279e79c3c51194a68548 /PKGBUILD
downloadaur-bc8fa4321290be7c2a542375d8aca9996e0f5470.tar.gz
* Initial commit for KeeAgent Beta.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..565f369e409d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Giancarlo Razzolinit <grazzolini@gmail.com>
+
+pkgname=keepass-plugin-keeagent-beta
+pkgver=0.7.2
+pkgrel=1
+pkgdesc="SSH Agent Plugin for KeePass - Beta Version"
+license=('BSD')
+depends=('keepass')
+provides=('keepass-plugin-keeagent-beta')
+conflicts=('keepass-plugin-keeagent')
+arch=('any')
+url="http://lechnology.com/software/keeagent/"
+DLAGENTS='http::/usr/bin/curl -fLC - --user-agent Firefox --retry 3 --retry-delay 3 -o %o %u'
+install=$pkgname.install
+source=('http://lechnology.com/wp-content/uploads/2015/07/KeeAgent_Beta_v0.7.2.zip' "$pkgname.install")
+sha512sums=('cac363471908f5acfd5ae5a28b3beed5d710af87273bbb2cb747a579562acfd6c37d430a3d1b00bc349cad75147b5579dc775afece292a04e6694e2ed2be1208'
+ 'af3e0d450c82053f6564dee90f0c3a4f7f06fec1bc4061a6eb4811cc0f5ce764635529aea8501e71f8ca7b3f08d01d9c791975a22bc737def3517232d1efd92a')
+
+package() {
+ mkdir -p "${pkgdir}"/usr/share/keepass/plugins
+ install -m644 KeeAgent.plgx "${pkgdir}"/usr/share/keepass/plugins/
+}