summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGerad Munsch2015-07-11 23:00:04 -0500
committerGerad Munsch2015-07-11 23:00:04 -0500
commitb589f7e14aff18e57058480f6763710c47664d58 (patch)
treec7ca2386031ddcd1f1e2917c4dafbc7f8b15e47f /PKGBUILD
downloadaur-b589f7e14aff18e57058480f6763710c47664d58.tar.gz
* keepass-plugin-keeotp: new package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3071f299089f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gerad Munsch <gmunsch@unforgivendevelopment.com>
+
+_pkgname=keeotp
+_pkgname2=KeeOtp
+pkgname=keepass-plugin-keeotp
+pkgver=1.3.6
+pkgrel=1
+pkgdesc="KeePass plugin that generates TOTPs from secrets stored in the KeePass database (ie: Google Authenticator, other RFC 6238 compliant TOTP implementations)"
+license=('MIT')
+depends=('keepass')
+provides=('keepass-plugin-keeotp')
+conflicts=('keepass-plugin-keeotp-beta')
+arch=('any')
+url="https://bitbucket.org/devinmartin/keeotp/wiki/Home"
+source=("https://bitbucket.org/devinmartin/keeotp/downloads/${_pkgname2}-${pkgver}.zip")
+sha512sums=('5110b258d56f875f342914c5bf27cbd5107461e5a0eb6f84a9736a1e4b56ca35c0434997ac239cc01990cdb2d363eae1f5dc8de34a02f35980004090af00ef0e')
+
+
+package() {
+ install -Dm644 "${srcdir}"/${_pkgname2}.plgx "${pkgdir}"/usr/share/keepass/plugins/${_pkgname2}.plgx
+ install -Dm644 "${srcdir}"/README.txt "${pkgdir}"/usr/share/keepass/plugins/${_pkgname2}-README.txt
+ install -Dm644 "${srcdir}"/LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
+}