summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorscan2019-06-04 17:43:11 -0300
committerscan2019-06-04 17:43:11 -0300
commit590990510acdbedc7bdc4aab4ec57c3e8c16742f (patch)
tree4e72aafe4c0cd9003ae078b32898b7e58fa1505f /PKGBUILD
parent3afdf97ef1f910322af8373cd4519f438c3e2d38 (diff)
downloadaur-590990510acdbedc7bdc4aab4ec57c3e8c16742f.tar.gz
Updated to 1.9.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 11 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 808f65123a7f..4c21fe94f90d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,16 @@
-# Maintainer: Tilman Blumenbach <tilman AT ax86 DOT net>
-#
-# Credits:
-# - Thanks to gamezelda and Magotchi for pointing out that newer versions
-# of the plugin are also hosted on GitHub, which makes downloading the
-# latest version a lot easier.
-
+# Maintainer: scan
pkgname=keepass-plugin-rpc
-epoch=1
-pkgver=1.8.0
-_git_tag=1.8.0
+pkgver=1.9.0
pkgrel=1
-pkgdesc="RPC plugin for Keepass (used by the KeeFox addon for Firefox)"
-arch=(any)
-url="https://github.com/kee-org/keepassrpc"
+pkgdesc="RPC plugin for Keepass"
license=('GPL')
-depends=(keepass)
-install="${pkgname}.install"
-source=("KeePassRPC-${pkgver}.plgx::https://github.com/kee-org/keepassrpc/releases/download/v${_git_tag}/KeePassRPC.plgx")
-
-package() {
- cd "$srcdir"
+depends=("keepass")
+url="https://github.com/kee-org/keepassrpc"
+source=(https://github.com/kee-org/keepassrpc/releases/download/v1.9.0/KeePassRPC.plgx)
+arch=(any)
+sha256sums=('4b24fc8e47ca70989a7d948397a4707913484027635ad5f8be7f96794cfe0309')
- install -m 644 -D "KeePassRPC-${pkgver}.plgx" "${pkgdir}/usr/share/keepass/plugins/KeePassRPC.plgx"
+package(){
+ mkdir -p "${pkgdir}"/usr/share/keepass/Plugins
+ install -m644 KeePassRPC.plgx "${pkgdir}"/usr/share/keepass/Plugins
}
-
-sha256sums=('8d9d5e390fc4a3b8d6d8f24dd26a712dc032c4ff49708c8ec32c95a2e27594b5')