summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSkycoder422019-03-09 18:33:50 +0100
committerSkycoder422019-03-09 18:33:50 +0100
commit504f026cb03142197dc5aae1714da9f7ddd52390 (patch)
tree054f00925837adfcd51b7886b892e160adfa9587 /PKGBUILD
parentaa4378892d971048fb218373b75438860b3b728d (diff)
downloadaur-504f026cb03142197dc5aae1714da9f7ddd52390.tar.gz
Patched to work with qt5-service>=2.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e52ec77fc977..171acf08e1f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,26 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=keepass-transfer
pkgver=3.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="A collection of tools to securely transfer passwords to your browser"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/KeepassTransfer"
license=('BSD')
-depends=('qt5-base' 'qt5-svg' 'qt5-mvvmwidgets' 'qt5-service' 'keepassxc-client-library' 'keepassxc')
+depends=('qt5-base' 'qt5-svg' 'qt5-mvvmwidgets' 'qt5-service>=2.0.0' 'keepassxc-client-library' 'keepassxc')
makedepends=('git' 'qt5-tools' 'pkgconfig' 'qpmx-qpmsource')
optdepends=("repkg: Automatically rebuild the package on dependency updates"
"keepassxc: Import credentials from KeePassXC for easy password transfers")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/KeepassTransfer.git#tag=$pkgver"
+ "qtservice.patch"
"$pkgname.rule")
sha256sums=('SKIP'
+ '3859a5e32b3dc273d11901126a8e7a428c081bc84fe9ea3c167a898c87f87cb0'
'1b8b79d7dea81de3866da764c67e12b80ffe66064acdcbcf53b9f2fac55c2e21')
prepare() {
cd "$_pkgfqn"
+ git apply ../qtservice.patch
git submodule update --init --recursive
cd ..
mkdir -p build