summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Lass2015-12-07 11:44:13 +0100
committerMichael Lass2015-12-07 11:44:13 +0100
commitdffba3afd83e0996d5d13280b4ad4ca737808da6 (patch)
tree6422f6e1f5489c756beb7e4b09ef164cc6f8841f /PKGBUILD
parentadbf8c23c946979c8fb39a732e1ce617a3d9dc67 (diff)
downloadaur-dffba3afd83e0996d5d13280b4ad4ca737808da6.tar.gz
Update to 2.0 stable
I also wrote an email to the maintainer of keepassx in [community], so this package may become obsolete soon.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d8b872086843..de1b7b5165fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,8 @@
# https://github.com/michaellass/AUR
pkgname=keepassx2
-pkgver=2.0beta2
+pkgver=2.0
pkgrel=1
-_dlver=2.0-beta2
-_dlno=115
pkgdesc="Crossplatform port of Windows' application ''KeePass Password Safe''"
arch=('i686' 'x86_64')
url="https://www.keepassx.org/dev/"
@@ -18,15 +16,15 @@ makedepends=('intltool' 'cmake')
conflicts=('keepassx' 'keepassx2-git')
options=(!emptydirs)
install=keepassx2.install
-source=("https://www.keepassx.org/dev/attachments/download/${_dlno}/keepassx-${_dlver}.tar.gz")
-sha256sums=('5828261226c441856bd12e2f4f73af1a5fc3b1981b2cff40fbc2403e344f4e52')
+source=("https://www.keepassx.org/releases/${pkgver}/keepassx-${pkgver}.tar.gz")
+sha256sums=('0eb40fac3a44d8283dfc1ee28cc6de5c660b22ab975472de82c2b04675c822e6')
_cmake_keys="-DCMAKE_INSTALL_PREFIX=/usr
-DCMAKE_INSTALL_LIBDIR=/usr/lib
-DCMAKE_BUILD_TYPE=Release"
build() {
- cd "${srcdir}/keepassx-${_dlver}"
+ cd "${srcdir}/keepassx-${pkgver}"
if [[ -d build ]]; then
rm -rf build
@@ -38,6 +36,6 @@ build() {
}
package() {
- cd "${srcdir}/keepassx-${_dlver}/build"
+ cd "${srcdir}/keepassx-${pkgver}/build"
make DESTDIR="${pkgdir}" install
}