aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsaber-nyan2018-09-09 12:52:36 +0300
committersaber-nyan2018-09-09 12:52:36 +0300
commit5eef5a9787da5fcf978585f94f1d09d300fbcb6f (patch)
tree8d3319fa858ae77eb1fd48f37c805c5b9a04651d /PKGBUILD
parenta43cd6bca2bbe65440f544e5f08d53b96c870903 (diff)
downloadaur-5eef5a9787da5fcf978585f94f1d09d300fbcb6f.tar.gz
Run ALPM-hooks before everything else
Closes #2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4821b4bd6745..3a51b242a48c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: saber-nyan <saber-nyan@ya.ru>
# Hooks: https://www.reddit.com/r/archlinux/comments/4zrsc3/keep_your_system_fully_functional_after_a_kernel/d6yin0r/
pkgname=kernel-modules-hook
-pkgver=0.1.1
+pkgver=0.1.2
pkgrel=1
pkgdesc="Keeps your system fully functional after a kernel upgrade"
arch=('any')
@@ -12,8 +12,8 @@ install="${pkgname}.install"
source=(
"linux-modules-cleanup.conf"
"linux-modules-cleanup.service"
- "linux-modules-post.hook"
- "linux-modules-pre.hook"
+ "10-linux-modules-post.hook"
+ "10-linux-modules-pre.hook"
)
sha256sums=(
"4169b44c297ddb7aad2220c6eba7c7942e3396f92528c59617955ab5560cb4cf"
@@ -25,6 +25,6 @@ sha256sums=(
package() {
install -Dm644 'linux-modules-cleanup.conf' "${pkgdir}/usr/lib/tmpfiles.d/linux-modules-cleanup.conf"
install -Dm644 'linux-modules-cleanup.service' "${pkgdir}/usr/lib/systemd/system/linux-modules-cleanup.service"
- install -Dm644 'linux-modules-post.hook' "${pkgdir}/usr/share/libalpm/hooks/linux-modules-post.hook"
- install -Dm644 'linux-modules-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/linux-modules-pre.hook"
+ install -Dm644 '10-linux-modules-post.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-post.hook"
+ install -Dm644 '10-linux-modules-pre.hook' "${pkgdir}/usr/share/libalpm/hooks/10-linux-modules-pre.hook"
}