summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBiteDasher2021-08-27 02:35:36 +0300
committerBiteDasher2021-08-27 02:35:36 +0300
commit8db74b71414beee4117ba0348df3fae2724a00d3 (patch)
treed8951579f92cb02e9c3b5ee1f207063b529c8da1 /PKGBUILD
parent5cf48bf0ed9df8f784ca8119db8536c4c79b7d3e (diff)
downloadaur-8db74b71414beee4117ba0348df3fae2724a00d3.tar.gz
Update makedepends, fix comment, add pkgver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 85000eddec1d..54a1eb6d623f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,23 @@
-# Author: Artemii Sudakov <finziyr@yandex.ru>
+# Maintainer: Artemii Sudakov <finziyr@yandex.ru>
pkgname="kesboot-git"
pkgver="1.0"
-pkgrel="1"
+pkgrel="2"
pkgdesc='Script for automating work with EFI Kernel Stub (linux)'
arch=('x86_64')
url="https://github.com/BiteDasher/kesboot"
license=('MIT')
-depends=('efibootmgr' 'sed' 'grep' 'util-linux' 'coreutils')
+depends=('efibootmgr' 'sed' 'grep' 'util-linux' 'coreutils' 'binutils')
+makedepends=('git')
source=("${pkgname}::git+https://github.com/BiteDasher/kesboot.git")
sha512sums=("SKIP")
+pkgver() {
+ git rev-parse --short HEAD
+}
package() {
cd "$srcdir/$pkgname"
export pkgdir
./install.sh makepkg
install -Dm755 ./firstboot "$pkgdir"/usr/lib/setup-efi-boot
+ install -Dm644 ./LICENSE "$pkgdir"/usr/share/licenses/kesboot/LICENSE
}