summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan Denhardt2018-02-02 17:34:02 -0500
committerIan Denhardt2018-02-02 17:34:02 -0500
commitea78726412ed1e183f966625cd5870ecb3aaa3b4 (patch)
tree8dc5b9f6b23d029573361ea8f999898a765b7fa1 /PKGBUILD
parent95e79fe03087ff322bd444ab757c171092f3ca99 (diff)
downloadaur-ea78726412ed1e183f966625cd5870ecb3aaa3b4.tar.gz
Update to 0.5.2, plus a few other changes.
* Use sha256 for checksums instead of md5 (why is md5 still the default?) * Add validpgpkeys and signature, per TrailnError's suggestion.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eaa1aa612474..17801783b1bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
# Maintainer: Ian Denhardt <ian@zenhack.net>
pkgname=keyringer
-pkgver=0.5.0
+pkgver=0.5.2
pkgrel=1
pkgdesc="Encrypted and distributed secret sharing software"
arch=(any)
url="https://keyringer.pw"
license=(GPL3)
depends=(gnupg git)
-source=("https://keyringer.pw/releases/$pkgname-$pkgver.tar.bz2")
+source=("https://keyringer.pw/releases/$pkgname-$pkgver.tar.bz2"
+ "https://keyringer.pw/releases/$pkgname-$pkgver.tar.bz2.asc")
+validpgpkeys=("4FA73DE89ADE75998AC24E97B8C1D523FE7AAA84")
package() {
cd "$srcdir/$pkgname-$pkgver"
make PREFIX=/usr DESTDIR="$pkgdir" install
}
-md5sums=('1bc62b934f3160ae27948932755e4cbf')
+sha256sums=('92244e572501f7c6ca0c463608f067813ee5e5b2184484eb21ece2914e78a01e'
+ 'SKIP')