summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJosef Vybíhal2021-08-04 09:28:12 +0200
committerJosef Vybíhal2021-08-04 09:28:12 +0200
commitf3216c0b7af8cb440bd5a372ae00e6d7d81deb1a (patch)
treea3aa9345dc2aac4175eed9ebe977fe04c90f5dc9 /PKGBUILD
parentbb3581fd70a0fef7f4458e6b34fcc8620a33de94 (diff)
downloadaur-f3216c0b7af8cb440bd5a372ae00e6d7d81deb1a.tar.gz
Added patch fixing build in gradle 7.x
Github issue 282: can't build latest release v5.4.4 with current gradle 7.1.1 https://github.com/kaikramer/keystore-explorer/issues/282 Thanks to @zeners for prodividing diff.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67709639f269..4b22ec7083cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# If you think this package is shit, contact me with patch
pkgname=keystore-explorer-git
-pkgver=v5.4.4+9+gbdf6b5f
+pkgver=v5.4.4+118+ga3c2c495
pkgrel=1
pkgdesc="KeyStore Explorer is a free GUI replacement for the Java command-line utilities keytool and jarsigner."
_pkgname=keystore-explorer
@@ -15,8 +15,13 @@ depends=('java-environment' 'bash' 'desktop-file-utils')
makedepends=('unzip' 'gradle' 'java-environment')
conflicts=('keystore-explorer' 'keystore-explorer-bin')
provides=('keystore-explorer')
-source=('git+https://github.com/kaikramer/keystore-explorer.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/kaikramer/keystore-explorer.git' 'fix282.patch')
+sha256sums=('SKIP' '8fc828930ab36564e2c947bd32d725a42a15aef7a734915bc92caef2a46586a1')
+
+prepare() {
+ cd "${_pkgname}"
+ patch --forward --strip=1 --input="${srcdir}/fix282.patch"
+}
pkgver() {
cd ${_pkgname}
@@ -67,4 +72,4 @@ package() {
# provide 'kse' command
ln -sf /opt/${_pkgname}/bin/${_short_pkgname} "${pkgdir}/usr/bin/${_short_pkgname}"
-} \ No newline at end of file
+}