summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimothy Redaelli2015-07-14 15:20:55 +0200
committerTimothy Redaelli2015-07-14 15:20:55 +0200
commit87a0276e144e5b8536c89429e2b1f7672683cc3f (patch)
tree4ed678f1edd7fbad279a7322d9eebc021c6beb36 /PKGBUILD
downloadaur-keysync.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4185d6d1ccc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+
+pkgname=keysync
+pkgver=0.2.1.1
+pkgrel=1
+pkgdesc='convert OTR keystores into other keystore formats for moving keys into a new IM app'
+arch=('any')
+url="https://guardianproject.info/apps/keysync/"
+makedepends=('desktop-file-utils' 'python2-setuptools')
+depends=('python2' 'python2-beautifulsoup3' 'python2-psutil' 'python2-python-potr'
+ 'python2-pyasn1' 'python2-crypto' 'python2-pyjavaproperties'
+ 'python2-pyparsing' 'python2-pgpdump' 'python2-qrcode' 'hicolor-icon-theme')
+optdepends=('tk: for GUI'
+ 'pymtp: for MTP on GUI')
+license=('GPL3')
+install=keysync.install
+sha256sums=('1002832c89a623b73a2964c8f83c455b377feb602fd6b898a62382ca40ea2f28')
+source=($pkgname-$pkgver.tar.gz::https://github.com/guardianproject/$pkgname/archive/${pkgver}.tar.gz)
+
+package() {
+ cd "$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}