summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAnton Kudelin2023-10-21 23:02:20 +0300
committerAnton Kudelin2023-10-21 23:02:20 +0300
commit662deff16a231e794e778563fe719218c06a7104 (patch)
treec5d7148ca4d8ed50a81e0c19e8bd3a94ff301717 /PKGBUILD
parent8a04b2f732aef4934dc50e744beef3b31fdc21e0 (diff)
downloadaur-kf5-kio-ftps.tar.gz
upddeps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 14 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec93842adf2f..05929415f131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
-# Maintainer: Anton Kudelin <kudelin at protonmail dot com>
+# Maintainer: Anton Kudelin <kudelin at proton dot me>
pkgname=kf5-kio-ftps
pkgver=0.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="Implements the ftp encryption scheme called ftps, based on rfc 4217"
-arch=("x86_64")
+arch=(x86_64)
url="https://github.com/Akimkin/kf5-kio-ftps"
-license=('GPL2')
-depends=('kio')
-makedepends=('extra-cmake-modules' 'kdelibs4support')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+license=(GPL2)
+depends=(kio5)
+makedepends=(extra-cmake-modules kdelibs4support)
+source=($pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz)
sha256sums=('da46c93a7e70ea98487ba911accf1e380e3da2abf64dd18ad37d45e12eda4ea5')
build() {
- mkdir "$srcdir/build"
- cd "$srcdir/build"
- cmake ../"$pkgname-$pkgver" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_CXX_FLAGS="-I/usr/include/KF5/KDELibs4Support $CXXFLAGS"
- make
+ cd "$srcdir"
+ cmake -B build -S $pkgname-$pkgver \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_CXX_FLAGS="-I/usr/include/KF5/KDELibs4Support $CXXFLAGS"
+ cmake --build build
}
package() {
- cd "$srcdir/build"
- make DESTDIR="$pkgdir" install
+ cd "$srcdir"
+ DESTDIR="$pkgdir" cmake --install build
}