summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAmeya Shenoy2021-09-10 13:12:58 +0530
committerAmeya Shenoy2021-09-10 13:12:58 +0530
commitcc80e3f542a598c235c8c915383adff8af587161 (patch)
tree92fd468db9f057bb83575d4baddeff827641b851 /PKGBUILD
downloadaur-cc80e3f542a598c235c8c915383adff8af587161.tar.gz
feat: initial commit to add kgctl-bin
Signed-off-by: Ameya Shenoy <shenoy.ameya@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f95328332e16
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Ameya Shenoy <archlinux@codingcoffee.me>
+
+_pkgname='kgctl'
+
+pkgname="$_pkgname-bin"
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="a command line tool provided by Kilo for inspecting and interacting with clusters"
+arch=('x86_64')
+url="https://github.com/squat/kilo"
+license=('Apache')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$_pkgname-$pkgver::https://github.com/squat/kilo/releases/download/$pkgver/$_pkgname-linux-amd64")
+sha256sums=('7dd9d4b610376d73ebb61ebecfa841031cc36bd3810bd145d83003e2b624ddc3')
+
+package() {
+ install -D -m755 "./$_pkgname-$pkgver" "$pkgdir/usr/bin/$_pkgname"
+}
+