summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-02 14:52:21 +0000
committerJoão Figueiredo2024-03-02 14:52:21 +0000
commitea15d619300f4bf851b3600c325d0fed484f789b (patch)
tree89f51d330f83d42207bcafddb322ec6cae93bfb4 /PKGBUILD
parent9e7c52b763badc0fc715561c33ed7f7a54fc37dc (diff)
downloadaur-khtml-git.tar.gz
Fix erroneous kf5-git dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5dcd4b8f933a..ccc1a78e0e05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=khtml-git
-pkgver=_r648.g01d7c39
+pkgver=5.116.0_r749.g93ae296
pkgrel=1
pkgdesc='KHTML APIs'
arch=($CARCH)
url='https://community.kde.org/Frameworks'
license=(LGPL)
-depends=(giflib kparts5-git kjs-git phonon-qt5-git)
+depends=(giflib kparts5 kjs-git phonon-qt5-git)
makedepends=(git extra-cmake-modules-git gperf)
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
@@ -17,6 +17,11 @@ groups=(kf5-aids-git)
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
+prepare() {
+ cd ${pkgname%-git}
+ git checkout kf5
+}
+
pkgver() {
cd ${pkgname%-git}
_ver="$(grep -m1 'set(KF5\?_VERSION' CMakeLists.txt | cut -d '"' -f2 | tr - .)"