summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpider.007 / Sjon2017-04-01 10:59:39 +0200
committerSpider.007 / Sjon2017-04-01 10:59:39 +0200
commit8913e7ec1412df130635fc7f6490a9a29649cccd (patch)
tree4973c2ee5eacc3be7b28f20ab9763c2d0c82bd52 /PKGBUILD
parent8c7d4b6645493ccf302dc59ca159e349e082897b (diff)
downloadaur-8913e7ec1412df130635fc7f6490a9a29649cccd.tar.gz
upgrade to 5.3.0; plus attempt to fix perms problems again
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 6 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a93f9f7002ab..186cccb4183c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Spider.007 <archlinux AT spider007 DOT net>
pkgname=kibana
-pkgver=5.2.2
+pkgver=5.3.0
pkgrel=1
pkgdesc="browser based analytics and search dashboard for Elasticsearch. Please note; this package replaces the distributed precompiled binary 'node'"
arch=('any')
@@ -13,7 +13,7 @@ options=('!strip')
source=(
"https://artifacts.elastic.co/downloads/$pkgname/$pkgname-$pkgver-linux-x86_64.tar.gz"
kibana.service)
-sha256sums=('9c7c526ce286da7f63aed9fb9f9d752ec182ff16bf374c55e55e5a0536a33563'
+sha256sums=('f31369c32d655370f0e51290018004cfbc54e2d648f0f79dba88e36b4d6cce6f'
'SKIP')
package() {
@@ -21,12 +21,9 @@ package() {
install -dm755 usr/share/kibana
install -Dm644 "$srcdir/kibana.service" usr/lib/systemd/system/kibana.service
+ install -Dm644 "$srcdir"/$pkgname-$pkgver-linux-x86_64/config/kibana.yml etc/elasticsearch/kibana/kibana.yml
- cd "$srcdir/$pkgname-$pkgver-linux-x86_64"
-
- install -Dm644 config/kibana.yml "$pkgdir"/etc/elasticsearch/kibana/kibana.yml
-
- rm -R ./node/
- chmod o+w optimize/
- cp -Rp * "$pkgdir"/usr/share/kibana/
+ rm -R "$srcdir"/$pkgname-$pkgver-linux-x86_64/node/
+ cp -Rp "$srcdir"/$pkgname-$pkgver-linux-x86_64/* usr/share/kibana
+ chmod -R g+w,o+w usr/share/kibana/{optimize,data}/
}