summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpider.007 / Sjon2015-11-05 09:29:23 +0100
committerSpider.007 / Sjon2015-11-05 09:29:23 +0100
commit8ba0eeb47dd4cac6d9ff4792847b4346a29d0524 (patch)
tree9791b503774043b34246fdec51907de9b21cafdf /PKGBUILD
parent96af1d981e911d8d4358d5ac662294b07b6518b2 (diff)
downloadaur-8ba0eeb47dd4cac6d9ff4792847b4346a29d0524.tar.gz
upgrade to 4.2, untested due to e/s-2 dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6308a8142138..63ea93ebcda6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,20 @@
# Contributor: Spider.007 <archlinux AT spider007 DOT net>
pkgname=kibana
-pkgver=4.1.2
-pkgrel=3
+pkgver=4.2.0
+pkgrel=1
pkgdesc="browser based analytics and search dashboard for Elasticsearch. Please note; this package replaces the distributed precompiled binary 'node'"
arch=('i686' 'x86_64')
url="http://www.elasticsearch.org/overview/kibana/"
license=('apache')
-makedepends=('git')
depends=('nodejs')
+optional=('elasticsearch>=2.0')
backup=('etc/elasticsearch/kibana/kibana.yml')
install=kibana.install
source=(
"https://download.elasticsearch.org/kibana/kibana/$pkgname-$pkgver-linux-x64.tar.gz"
kibana.service)
-[[ $CARCH == 'i686' ]] && ${source[0]}=${source[0]/x64/x86}
-md5sums=('2210a838f9c7171d1385b0825ba19382'
- 'SKIP')
+sha256sums=('67d586e43a35652adeb6780eaa785d3d785ce60cc74fbf3b6a9a53b753c8f985'
+ 'SKIP')
package() {
cd "$srcdir/`basename ${source[0]%.tar.gz}`"
@@ -23,6 +22,9 @@ package() {
mkdir -p $pkgdir/usr/lib/kibana/
install -Dm644 "$srcdir/kibana.service" "$pkgdir/usr/lib/systemd/system/kibana.service"
install -Dm644 "config/kibana.yml" "$pkgdir/etc/elasticsearch/kibana/kibana.yml"
- chmod +r src/public/worker-json.js
- cp -Rp src/* "$pkgdir/usr/lib/kibana/"
+
+ rm -R ./node/
+ chmod +r -R src/
+ find src -type d -exec chmod +x {} \;
+ cp -Rp * "$pkgdir/usr/lib/kibana/"
}