summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSpider.007 / Sjon2015-07-09 13:35:14 +0200
committerSpider.007 / Sjon2015-07-09 13:35:14 +0200
commitc0a344e3bb93eea21bb6f7f75496f9e01f38be38 (patch)
treef6f9e21a2477bb1850ec6458cc9436f477e36153 /PKGBUILD
parent3d2a3267f7ec30bf4b2f4e4b97de7d161e72442e (diff)
downloadaur-c0a344e3bb93eea21bb6f7f75496f9e01f38be38.tar.gz
updated to version 4.1.1, further stripped upstream build of crap
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 11 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fe73d740558f..75662dc29fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Contributor: Spider.007 <archlinux AT spider007 DOT net>
pkgname=kibana
-pkgver=4.1.0
+pkgver=4.1.1
pkgrel=1
pkgdesc="browser based analytics and search dashboard for Elasticsearch. Please note; this package replaces the distributed precompiled binary 'node'"
arch=('i686' 'x86_64')
@@ -8,24 +8,20 @@ url="http://www.elasticsearch.org/overview/kibana/"
license=('apache')
makedepends=('git')
depends=('nodejs')
-backup=('etc/webapps/kibana/kibana.yml')
+backup=('etc/elasticsearch/kibana/kibana.yml')
install=kibana.install
source=(
- kibana.service
- "https://download.elasticsearch.org/kibana/kibana/$pkgname-${pkgver/r/-r}-linux-x64.tar.gz")
+ "https://download.elasticsearch.org/kibana/kibana/$pkgname-$pkgver-linux-x64.tar.gz"
+ kibana.service)
[[ $CARCH == 'i686' ]] && ${source[1]}=${source[1]/x64/x86}
-md5sums=('SKIP'
- '77b65888f0ab6b8fa403732b3bf9fbe5')
+md5sums=('3a9bba5bb5e883851904fde9b79c291f'
+ 'SKIP')
package() {
- p=$srcdir/`basename ${source[1]%.tar.gz}`
- mkdir -p $pkgdir/usr/{share/webapps/kibana,lib/systemd/system} $pkgdir/etc/webapps/
- mv $p/config $pkgdir/etc/webapps/kibana
- cp -Rp $p/* $pkgdir/usr/share/webapps/kibana/
- cp $srcdir/kibana.service $pkgdir/usr/lib/systemd/system/
- ln -s /etc/webapps/kibana/ $pkgdir/usr/share/webapps/kibana/config
+ cd "$srcdir/`basename ${source[0]%.tar.gz}`"
- # If you want the vanilla experience, remove these 2 lines to use the distributed binary
- rm $pkgdir/usr/share/webapps/kibana/node/bin/node
- ln -s /usr/bin/node $pkgdir/usr/share/webapps/kibana/node/bin/node
+ mkdir -p $pkgdir/usr/lib/kibana/
+ install -Dm644 "$srcdir/kibana.service" "$pkgdir/usr/lib/systemd/system/kibana.service"
+ install -Dm644 "config/kibana.yml" "$pkgdir/etc/elasticsearch/kibana/kibana.yml"
+ cp -Rp ./src/* "$pkgdir/usr/lib/kibana/"
}