summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Østergaard2018-01-31 18:12:04 +0100
committerNick Østergaard2018-01-31 18:12:04 +0100
commit0d542efebdb3f6c02bedc70fa28c9090a42bac04 (patch)
tree8a6da2bb57fd18ba3432913798eaa4cd7673d59a /PKGBUILD
parent3f58b678f2e59e60a90b2b927401f708406ad008 (diff)
downloadaur-0d542efebdb3f6c02bedc70fa28c9090a42bac04.tar.gz
Add ngspice as a depend
We require ngspice 27 because it has a fix that is needed for kicad.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6c78c8bd2a1e..7f5794f2550a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
pkgname=kicad-git
-pkgver=r9217.8721f7ed7
-pkgrel=1
+pkgver=r9341.e69ddf0e1
+pkgrel=2
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="http://kicad-pcb.org/"
license=('GPL')
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython' 'oce')
+depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython' 'oce' 'ngspice>=27')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-library: for footprints')
conflicts=('kicad' 'kicad-bzr')
@@ -36,8 +36,6 @@ build() {
-DKICAD_SCRIPTING_WXPYTHON=ON \
-DKICAD_SCRIPTING_ACTION_MENU=ON
- # -DKICAD_SPICE=ON is not yet added because it really depends an
- # unreleased version of ngspice...
make
}