summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Østergaard2019-03-01 22:47:11 +0100
committerNick Østergaard2019-03-01 22:50:40 +0100
commit20a57f7ff5f0cefafa8a5b5f0b27de8c18beb30b (patch)
tree79e9abdb422b72aa3f8b140aebc287779097e3de /PKGBUILD
parent7084e207a71f844ff79ad9a5fb48c621d1fcd309 (diff)
downloadaur-20a57f7ff5f0cefafa8a5b5f0b27de8c18beb30b.tar.gz
Use glm-git to be able to build with gcc again
You may need to clear your build dir.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a9992448130b..d59a2f7579fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
pkgname=kicad-git
-pkgver=r12145.f5144eb5c
-pkgrel=3
+pkgver=r12473.16b3c80a7
+pkgrel=1
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="http://kicad-pcb.org/"
license=('GPL')
depends=('glew' 'wxgtk3' 'desktop-file-utils' 'boost-libs' 'python'
- 'glm' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27')
-makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost' 'clang')
+ 'glm-git' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27')
+makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-library: for footprints')
conflicts=('kicad' 'kicad-bzr')
provides=('kicad')
@@ -26,7 +26,6 @@ build() {
cd "${srcdir}/${pkgname}"
mkdir -p build
cd build
- export CXX=clang++
cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \