summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Østergaard2022-08-28 21:39:38 +0200
committerNick Østergaard2022-08-28 21:40:51 +0200
commit48910d578f414be59716aa6d025ef94328b04c9e (patch)
tree195239345282bff7fb974f7a9626ec01b0086a7f /PKGBUILD
parent684b7f44363ddfa2e2ffb5d40f2f40281e85b419 (diff)
downloadaur-48910d578f414be59716aa6d025ef94328b04c9e.tar.gz
Update for newer wxwidgets and enable EGL
I am not sure why the EGL switch is needed, but it appears to be for me to be able to build.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6008b145232b..18566bf6b7ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
pkgname=kicad-git
-pkgver=5.99.0.r12888.gc5e5d8e0d4
+pkgver=6.99.0.r3101.g667a54ad86
pkgrel=1
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="https://kicad.org/"
license=('GPL')
-depends=('glew' 'wxgtk3' 'desktop-file-utils' 'boost-libs' 'python'
+depends=('glew' 'wxwidgets-gtk3' 'desktop-file-utils' 'boost-libs' 'python'
'glm' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-library: for footprints')
@@ -31,13 +31,13 @@ build() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DKICAD_USE_OCE=OFF \
-DKICAD_USE_OCC=ON \
+ -DKICAD_USE_EGL=ON \
-DBUILD_GITHUB_PLUGIN=ON \
-DKICAD_SCRIPTING=ON \
-DKICAD_SCRIPTING_MODULES=ON \
-DKICAD_SCRIPTING_ACTION_MENU=ON \
-DKICAD_SCRIPTING_PYTHON3=ON \
-DKICAD_SCRIPTING_WXPYTHON=ON \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
-DCMAKE_EXE_LINKER_FLAGS=-fuse-ld=gold \
-DKICAD_SCRIPTING_WXPYTHON_PHOENIX=ON