summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Østergaard2019-01-12 15:37:04 +0100
committerNick Østergaard2019-01-12 15:38:22 +0100
commit7084e207a71f844ff79ad9a5fb48c621d1fcd309 (patch)
tree7bae1c42f0b928fccc257a01f0a8a4eb54b5289e /PKGBUILD
parentf6f8d522983a668f188bcad4574187ada9fa6921 (diff)
downloadaur-7084e207a71f844ff79ad9a5fb48c621d1fcd309.tar.gz
Use python3 and wxpython version 4 aka phoenix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b11877448e58..a9992448130b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=kicad-git
pkgver=r12145.f5144eb5c
-pkgrel=2
+pkgrel=3
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="http://kicad-pcb.org/"
license=('GPL')
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python'
- 'glm' 'curl' 'swig' 'wxpython' 'opencascade' 'ngspice>=27')
+depends=('glew' 'wxgtk3' 'desktop-file-utils' 'boost-libs' 'python'
+ 'glm' 'curl' 'swig' 'python-wxpython' 'opencascade' 'ngspice>=27')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost' 'clang')
optdepends=('kicad-library: for footprints')
conflicts=('kicad' 'kicad-bzr')
@@ -35,8 +35,11 @@ build() {
-DBUILD_GITHUB_PLUGIN=ON \
-DKICAD_SCRIPTING=ON \
-DKICAD_SCRIPTING_MODULES=ON \
- -DKICAD_SCRIPTING_WXPYTHON=OFF \
- -DKICAD_SCRIPTING_ACTION_MENU=ON
+ -DKICAD_SCRIPTING_ACTION_MENU=ON \
+ -DKICAD_SCRIPTING_PYTHON3=ON \
+ -DKICAD_SCRIPTING_WXPYTHON=ON \
+ -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-gtk3 \
+ -DKICAD_SCRIPTING_WXPYTHON_PHOENIX=ON
make
}