summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel A. Winchenbach2017-01-05 08:45:21 -0500
committerSamuel A. Winchenbach2017-01-05 08:45:21 -0500
commitc212f9565b3af4abbc234cb2bad7a58d7756b93c (patch)
tree151ae20a5d7ae0290c4689f5a9923fac1c1c2dff /PKGBUILD
parenteb19ed5de5ab41e705c4f6087e5c57f34f428cb7 (diff)
downloadaur-c212f9565b3af4abbc234cb2bad7a58d7756b93c.tar.gz
Enabled scripting
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fce809b4fddb..264af486e846 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
# Contributor: Marq Schneider <queueRAM@gmail.com>
pkgname=kicad-git
-pkgver=r7336.86dcfeb
+pkgver=r7432.50cdd5cdf
pkgrel=1
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="http://kicad-pcb.org/"
license=('GPL')
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl')
+depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-library: for footprints')
conflicts=('kicad' 'kicad-bzr')
@@ -27,11 +27,12 @@ build() {
cd "${srcdir}/${pkgname}"
mkdir -p build/Release
cd build/Release
- # -DKICAD_SCRIPTING=ON -DKICAD_SCRIPTING_MODULES=ON ?
- # -DKICAD_SCRIPTING_WXPYTHON=ON ?
cmake ../.. -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DBUILD_GITHUB_PLUGIN=ON
+ -DBUILD_GITHUB_PLUGIN=ON \
+ -DKICAD_SCRIPTING=ON \
+ -DKICAD_SCRIPTING_MODULES=ON \
+ -DKICAD_SCRIPTING_WXPYTHON=ON
make #-j1
}