summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNick Østergaard2018-08-02 20:52:45 +0200
committerNick Østergaard2018-08-02 20:52:45 +0200
commitd1ec050d374f29f034e0f4bd830e6262a6ab9e2f (patch)
tree35e340b18bc231c95aff6192797a68f89c0a057a /PKGBUILD
parent15ab44999bbdca83bd44c4ac7a7b31500fe6bee1 (diff)
downloadaur-d1ec050d374f29f034e0f4bd830e6262a6ab9e2f.tar.gz
Use OCC instead of OCE
Freecad uses OCC, so we will also attempt to use this by default
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8532f10fba61..3734ec90bd98 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
# Maintainer: Nick Østergaard <oe.nick at gmail dot com>
pkgname=kicad-git
-pkgver=r9486.28f1209ce
+pkgver=r10854.8e7d6063f
pkgrel=1
pkgdesc="Electronic schematic and printed circuit board (PCB) design tools"
arch=('i686' 'x86_64')
url="http://kicad-pcb.org/"
license=('GPL')
-depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python' 'glm' 'curl' 'swig' 'wxpython' 'oce' 'ngspice>=27')
+depends=('glew' 'wxgtk' 'desktop-file-utils' 'boost-libs' 'python'
+ 'glm' 'curl' 'swig' 'wxpython' 'opencascade' 'ngspice>=27')
makedepends=('cmake' 'git' 'zlib' 'mesa' 'boost')
optdepends=('kicad-library: for footprints')
conflicts=('kicad' 'kicad-bzr')
@@ -28,7 +29,8 @@ build() {
cmake .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DKICAD_USE_OCE=ON \
+ -DKICAD_USE_OCE=OFF \
+ -DKICAD_USE_OCC=ON \
-DOCE_DIR=`dirname $(pacman -Ql oce | grep OCEConfig.cmake | awk '{ print $2 }' )` \
-DBUILD_GITHUB_PLUGIN=ON \
-DKICAD_SCRIPTING=ON \