summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrederic Van Assche2018-01-24 12:23:46 +0100
committerFrederic Van Assche2018-01-24 12:23:46 +0100
commitfde1c10d7f26e395adeebae043a9083cf009a851 (patch)
treea060f00c54099aeef4dfa1d0ed9e849dffcbe29a /PKGBUILD
parentebd34a529000f4a34b0ef3cfc5445677943fb4e9 (diff)
downloadaur-fde1c10d7f26e395adeebae043a9083cf009a851.tar.gz
Better pkgver function
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5adb9a8ac3cc..db014c0d5a5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
pkgname=kicad-packages3d-git
_pkgname=kicad-packages3D
-pkgver=4e34135f
-pkgrel=2
+pkgver=r674.4e34135f
+pkgrel=1
pkgdesc="Official KiCad 3D model libraries for rendering and MCAD integration"
arch=('any')
url="https://github.com/KiCad/kicad-packages3D"
@@ -16,7 +16,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git rev-parse --short HEAD # Fix to better comply with github display
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {