summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGrey Christoforo2021-01-16 19:45:21 +0100
committerGrey Christoforo2021-01-16 19:45:21 +0100
commit962366a497cf299bfc7998d57321384298224119 (patch)
tree6cbb16f84c59664d0eb0da8c1794144d02bc15e2 /PKGBUILD
parentd9feebe1f9d7ef01e2c47c4c5e6a75288bd887a8 (diff)
downloadaur-962366a497cf299bfc7998d57321384298224119.tar.gz
minor build updates
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 31 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e18e564857a8..235f497ec36b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,67 +6,67 @@ pkgver=${_pkgver//-/_}
pkgrel=1
pkgdesc="Official KiCad release candidates and dev snapshots"
arch=(x86_64)
-url="http://kicad-pcb.org/"
+url="http://kicad.org/"
license=(GPL3 AGPL3 BOOST ISC MIT CC-BY-SA)
depends=(
-glew
-wxgtk3
-desktop-file-utils
-boost-libs
-python
-glm
-curl
-swig
-python-wxpython
-opencascade
-ngspice
+ glew
+ wxgtk3
+ desktop-file-utils
+ boost-libs
+ python
+ glm
+ curl
+ swig
+ python-wxpython
+ opencascade
+ ngspice
+ libcloudproviders
)
makedepends=(
-cmake
-git
-zlib
-mesa
-boost
+ cmake
+ git
+ zlib
+ mesa
+ boost
+ swig
)
optdepends=(
-kicad-symbols
-kicad-packages3d
-kicad-footprints
-kicad-templates
+ kicad-symbols
+ kicad-packages3d
+ kicad-footprints
+ kicad-templates
)
conflicts=('kicad' 'kicad-git' 'kicad-scripting-git' 'kicad-bzr')
provides=('kicad')
-makedepends=('clang')
source=("${pkgname}:${pkgver}.tar.gz::https://gitlab.com/kicad/code/kicad/-/archive/${_pkgver}/kicad-${_pkgver}.tar.gz")
sha256sums=('841be864b9dc5c761193c3ee9cbdbed6729952d7b38451aa8e1977bdfdb6081b')
prepare() {
- cd "${srcdir}/kicad-${_pkgver}"
- #curl https://github.com/KiCad/kicad-source-mirror/commit/5685174808f5ca973e916a10f9f93660ee4dc4f2.patch | patch -p1
+ cd kicad-${_pkgver}
}
build() {
- cd "${srcdir}/kicad-${_pkgver}"
+ cd kicad-${_pkgver}
cmake \
+ -W no-dev \
-D CMAKE_BUILD_TYPE=None \
-D CMAKE_INSTALL_PREFIX=/usr \
- -D CMAKE_INSTALL_LIBDIR=lib \
-D KICAD_USE_OCC=ON \
-D KICAD_USE_OCE=OFF \
-D KICAD_SCRIPTING_WXPYTHON_PHOENIX=ON \
- -D PYTHON_EXECUTABLE:FILEPATH=/usr/bin/python \
-D KICAD_SCRIPTING_PYTHON3=ON \
-D wxWidgets_CONFIG_EXECUTABLE="$(which wx-config-gtk3)" \
-D USE_WX_GRAPHICS_CONTEXT=ON \
-D USE_WX_OVERLAY=ON \
-G Ninja \
- -B "${srcdir}"/build_dir \
+ -B build_dir \
-S .
- ninja -C "${srcdir}"/build_dir
+
+ cmake --build build_dir
}
package() {
- cd "${srcdir}/kicad-${_pkgver}"
- DESTDIR="${pkgdir}" ninja -C "${srcdir}/build_dir" install
+ cd kicad-${_pkgver}
+ DESTDIR="${pkgdir}" cmake --build build_dir -- install
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" -m644 LICENSE.{AGPLv3,GPLv3,README,BOOSTv1_0,ISC,CC-BY-SA-4.0,MIT}
}