summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrej Radovic2017-09-23 17:14:28 +0200
committerAndrej Radovic2017-09-23 17:14:28 +0200
commit37cf126b947f740ba534b75293f8f7890c599f36 (patch)
tree8a4adc4d653f08b6c443dd4b503a733885d23c15 /PKGBUILD
parent22d7a0a4644455537ec0a408feb48887a627ed71 (diff)
downloadaur-37cf126b947f740ba534b75293f8f7890c599f36.tar.gz
Changed the pkgver() method to a more sensible one
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 35fdd579c7e7..ba2cc9407e8d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Andrej Radovic <r.andrej@gmail.com>
pkgname="kicadlibrarian-git"
-pkgver=r32.eccc226
+pkgver=20170817.81f6567
pkgrel=1
pkgdesc="A utility to manage and maintain KiCad libraries with schematic symbols and footprints"
arch=('i686' 'x86_64')
@@ -16,7 +16,7 @@ md5sums=('SKIP')
pkgver() {
cd "$srcdir/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ echo "$(git log -1 --format="%cd" --date=short | tr -d '-').$(git log -1 --format="%h")"
}
build() {