summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Figueiredo2024-03-26 04:17:52 +0000
committerJoão Figueiredo2024-03-26 04:17:52 +0000
commit3035960b708e23aac10c17b402c939648cb5bd2a (patch)
treead15a80f232d412d38abb96fe3f5c95e494738a1 /PKGBUILD
parent627b7d5f46e819a68b1ea852c8fde900eea054bb (diff)
downloadaur-3035960b708e23aac10c17b402c939648cb5bd2a.tar.gz
Fix deps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 6 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd317244f490..029cf555220b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,22 @@
# Contributor: vnoel <victor.noel at crazydwarves dot org>
pkgname=kile-git
-pkgver=3.0b2_r3569.g66599ab1
+pkgver=3.0b4_r3616.g2f49c0c8
pkgrel=1
pkgdesc='A user friendly TeX/LaTeX frontend for KDE'
arch=($CARCH)
url='https://apps.kde.org/kile/'
-license=(GPL-2.0-only)
-depends=(gcc-libs glibc kcodecs-git kcompletion-git kconfig-git kconfigwidgets-git kcoreaddons-git kcrash-git kdbusaddons-git kguiaddons-git ki18n-git kiconthemes-git kinit-git kio-git kjobwidgets-git kparts-git kservice-git ktexteditor-git ktextwidgets-git kwidgetsaddons-git kwindowsystem-git kxmlgui-git okular-git kcolorscheme-git hicolor-icon-theme perl poppler-qt6 qt6-base qt6-script qt6-5compat qt6-declarative texlive-basic)
-makedepends=(git extra-cmake-modules-git kdoctools-git okular-git)
-optdepends=('konsole-git: embedded terminal' 'imagemagick: for some file type conversions')
+license=(GPL-2.0-or-later)
+depends=(gcc-libs glibc kcodecs-git kcolorscheme-git kcompletion-git kconfig-git kconfigwidgets-git kcoreaddons-git kcrash-git kdbusaddons-git kguiaddons-git ki18n-git kiconthemes-git kio-git kparts-git kservice-git ktexteditor-git ktextwidgets-git kwidgetsaddons-git kwindowsystem-git kxmlgui-git okular-git perl poppler-qt6 qt6-5compat qt6-base qt6-declarative texlive-basic)
+makedepends=(git extra-cmake-modules-git kdoctools-git)
+optdepends=('imagemagick: for some file type conversions'
+ 'konsole-git: embedded terminal')
conflicts=(${pkgname%-git})
provides=(${pkgname%-git})
source=("git+https://github.com/KDE/${pkgname%-git}.git")
sha256sums=('SKIP')
-prepare() {
- cd ${pkgname%-git}
- git checkout work/carl/kf6
-}
-
pkgver() {
cd ${pkgname%-git}
_ver="$(git describe | sed 's/^v//;s/-.*//')"