summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Schopf2019-02-03 11:29:07 +0100
committerDaniel Schopf2019-02-03 11:30:19 +0100
commitf27304b89154cef8095202d5ed6fab66a7b1cf28 (patch)
treecd0a5fe30bc959282b13a9a4efd7be45dbf825c2 /PKGBUILD
parent64bd4a22d174b666aab87f959524bfd6f9eb93e1 (diff)
downloadaur-f27304b89154cef8095202d5ed6fab66a7b1cf28.tar.gz
Backport a fix for installing models and fix CMake build issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b839b374af5..d2a4315c68ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Schopf <schopf.dan at gmail dot com>
pkgname=kim-api
pkgver=2.0.0_beta.3
-pkgrel=1
+pkgrel=2
pkgdesc="Online framework for reliable, reproducible and portable molecular simulations"
arch=("i686" "x86_64")
url="https://openkim.org"
@@ -9,10 +9,18 @@ license=('CDDL')
depends=(bash)
makedepends=(gcc-libs)
install=$pkgname.install
-source=("https://s3.openkim.org/kim-api/kim-api-v2-2.0.0-beta.3.txz")
-md5sums=('67c103a00e84865848d004837262c76e')
+source=(https://s3.openkim.org/kim-api/kim-api-v2-2.0.0-beta.3.txz
+ Fix-major-version-variable-name-in-CM.patch
+ Fix-Doxygen-command-error.patch)
+sha512sums=('22ec9661a48753676de3a20990ad712feab9c0ca0519e3c45f98d3a5ad49d3f0b33496968ac3cfe9f2c0d5bf52ea6dbd47c0283f61b35222f5fa7d1e1ccf3ed5'
+ 'a525539af26238560e310aa7ad23eec75fd87b1f2f82280ace8d61630c41b7780cabfdfa561d6d235101126e74e9d50ee4b767f992dd37948defa3ec589df318'
+ 'e2771561f05b49b7ed46b265af6a2c81ad8fbde9e6ab9f2632822764de5802ac0e91973e66d5240136ea7e9a8b82befc312dbbb3bccdb84d8875744851fcb146')
prepare() {
+ cd "kim-api-v2-2.0.0-beta.3"
+ patch -p1 -i ../Fix-major-version-variable-name-in-CM.patch
+ patch -p1 -i ../Fix-Doxygen-command-error.patch
+ cd ..
mkdir -p build
}